Resolved
Delays and issues with outbound emails

Started
June 09, 2022 at 12:20 PM
Status
Resolved after about 12 hours
Affected
Notifications
Email
Dashboard

Impact

Degraded performance
  • Resolved
    June 10, 2022 at 12:00 AM

    Mailgun resolved the issue earlier. Everything should be up and running!

  • Identified
    June 09, 2022 at 12:20 PM

    Mailgun was having issues with email delivery. That lead to some of our login emails and notifications delivered late to recipients.

    Mailgun fixed the issue and they're currently monitoring the results.